Buggy Icom ID-51 and ID-5100 Firmware – UPDATED

On November 6th 2019 and December 5th 2019 Icom released new firmware. According to Icom’s claim on their latest release it fixes issues with “other manufacturers” hardware and that there were no issues with Icom or Kenwood gear. Sorry Icom, this is plainly wrong.

Update December 15th 2019

Icom released a new firmware set for the ID-51 Plus, ID-51 Plus 2, ID-5100 and ID-4100. It seems that after three versions they managed to get things sorted out. I ran through all the tests below on my ID-51 and they all passed. We hope that Icom will improve their QA for upcoming releases

This article will be kept online for archive purpose.

Symptoms

Both MMDVM and Icom gear failed to receive end of transmission frame. It seems like the end of transmission frame isn’t transmitted by the ID-51. Here are some test cases to narrow the up the cause of the issue.

Tests Against MMDVM Gear

Test Environment

Test 1

  • Apply following settings on ID-51 : GPS Mode set to off
  • Briefly key the radio (approx 1sec)

Expected Result

The repeater immediately answers back with BER value

Actual Result

Repeater answers back with BER value.

Test passed.

Test 2

  • Apply following settings on ID-51 : GPS Mode set to DV-A, make sure GPS position has been acquired.
  • Briefly key the radio (approx 1sec)

Expected Result

The repeater immediately answers back with BER value

Actual Result

Once the ID-51 PTT is released the repeaters transmits garbled signals (R2D2). Analysis of debug information on the repeater shows following messages it seems that the End of Transmission frame is never sent and that the ID-51 somehow switched to fast data mode.

Test Failed

Tests Against Icom Gear

Test Environment

Test 1

  • Apply following settings on ID-51 : GPS Mode set to off
  • Briefly key the radio (approx 1sec)

Expected Result

The end of transmission beep can be heard on the IC-E92D immediately after releasing the PTT on the ID-51

Actual Result

The end of transmission beep is heard immediately on the IC-E92D after releasing the PTT on the ID-51.

Test Passed

Test 2

  • Apply following settings on ID-51 : GPS Mode set to DV-A, make sure GPS position has been acquired.
  • Briefly key the radio (approx 1sec)

Expected Result

The end of transmission beep is heard immediately on the IC-E92D after releasing the PTT on the ID-51

Actual Result

The end of transmission beep is only heard on the IC-E92D approximately 3 seconds after having released the PTT on the ID-51

Test Failed

Conclusion

The ID-51 E3 release somehow switches to Fast Data Mode as soon as it transmits GPS Data. Once it does this it does not send the End of Transmission frame.

This behavior confuses both MMDVM gear and Icom gear. Both will then wait for a timeout and then decide the transmission is gone. Hence the 3s delay on the IC-E92D before end of transmission beep and the garbled R2D2 tail signal on the MMDVM.

The workaround is to switch of GPS data.

Downgrading the ID-51E Anniversary Edition to firmware release pre-November 5th solved the issue.

5 Comments:

  1. Hello, I noticed thjis as well. I opended a Ticket at Icom Europe and later on at Icom Headquater. I have sent videos for ID51plus, ID4100 and ID5100 as well as IC9700 to them.
    I also sent your link to Icom Headquater as well.
    I requested to deliver E1 Firmware for the ID4100 because it is not available so no downgrade possible.
    Hopefully they will react and fix the problems. It seam that it is a general problem with the DD Mode, not only with GPS in Fast Data Mode.

    • Hi Stefan,

      I have searched for a way to submit tickets to Icom but did not find any. I am glad you did. The E2 ID-51 release was even worse, first second of the audio was broken.
      Using ECHO function and counting “1,2,3” only “2,3” would be echoed.
      I downgraded my ID-51 Anniversary, now it is working fine again.

      So you confirm the bug also affects the ID4100 ?

    • Hi, there is a new firmware out. It seems to work on my ID-51. Did you ever had any sort of feedback from Icom ?

  2. I followed up all the time with Icom. They did good comunication and expained every step they did. Also IC9700 got an update. Looks like it was a general problem .

    • It looks like you have good connections with them. When the issues first arised they ne3ver ever came back to me when I tried to reach out to them via social media.
      Could you maybe use your conenctions to have them improve the reflector menu to include XRF and DCS ? πŸ˜‰

Leave a Reply to F4FXL Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.